2011年05月06日

エラー値: 2147943730 タスクスケジューラ上で起動エラー

グループウェアはGroupSessionに決まり、Windows Server 2008 R2 評価版を使っての導入テスト、バックアップ等のスケジュールの設定も完了し、後はサーバ機の納品を待ってインストールするだけ、となったところで東日本大震災が発生、このあたりも甚大な被害を受け、それ以来サーバの導入どころではなくなってしまっていました。
それで今日からようやく再開、テスト機の動作確認をしたところ、4月11日以降、タスクスケジューラ上に設定した各種データのバックアップ、定時のサーバ再起動等のスケジュールが実行されていません。

ログ上にはこのような文言が残っています。
"タスク スケジューラは、ユーザー "(コンピューター名)\Administrator" の "\GroupSession バックアップ" タスクを開始できませんでした。追加データ: エラー値: 2147943730。"

このエラー番号で検索・・・
"2147943730 0x80070532 ログオン失敗: 指定されたアカウント パスワードの有効期間が切れています。"

だそうです。
そういえば、今日ログインしたときにパスワードの変更を求められ、変更したのを思い出しました。このテスト機は3月末まで簡単な動作チェックはしてたんですが、それ以降今日まで、誰も操作していなかったようです。
タスクスケジューラのユーザー(Admin)のパスワードを新しく設定したものに変更し、正常動作を確認しました。

後で思い出してグループポリシーおよびローカルセキュリティポリシーのパスワードポリシーを変更したんですが、まだテスト段階で助かりました。

参考サイト(csvファイル):
http://www5d.biglobe.ne.jp/~noocyte/Programming/Windows/Errors/WinXP-SP2-Error-JP.csv

posted by nambei-x at 10:59| Comment(0) | TrackBack(0) | PC・ネット関連 | このブログの読者になる | 更新情報をチェックする

2011年03月03日

WSS3.0 を80番以外のポートに設定してインストールする場合の備忘録(結局断念編)

Windows Server 2008 R2 評価版、いろいろいじりすぎたせいか、動作が猛烈に重くなってしまいました。タスクマネージャ上ではCPUの稼働率は常時30%以上をキープ、外からのアクセスにも全然反応が遅く、こりゃ駄目だ、ということでOSのクリーンインストールを実行しました。
今回は前回のインストール分からWSUS3.0、SQL Server 2005 Express Edition、デスクトップ エクスペリエンス を抜いた形ですが、これだけで随分動作が軽くなりました。



で、SharePoint Servicesも再インストールしまして、デフォルトの80番ポートのまま、ユーザー登録、GroupBoard のインストール、スケジュール登録等を行ったところで再度ポート変更を行ってみることにしました。
前回はMicrosoftのサイトが発見できず、自力でやった結果おかしなことになりましたが、今回は下記のサイトを参考に、サクッと解決(たぶん?)です。

参考サイト:
Microsoft Technet - Web アプリケーション URL と IIS バインドを更新する (Windows SharePoint Services)

1.管理ツール→SharePoint 3.0 サーバーの全体管理→「アプリケーション構成の管理」タブをクリック
2.「SharePoint Web アプリケーション構成の管理」の「IIS Web サイトからの SharePoint の削除」リンクをクリック
3.画面右
  「Webアプリケーション」:SharePoint - 80
  「削除するIIS Webサイトと領域の選択」:SharePoint - 80(既定)
  「IIS Webサイトを削除する」:はい(他にIISが関係するコンテンツが存在しないので)  →  「OK」をクリック
4.「SharePoint Web アプリケーション構成の管理」の「Web アプリケーションの作成または拡張」リンクをクリック→画面右「既存の Web アプリケーションの拡張」リンクをクリック
5.画面右
  「Webアプリケーション」:SharePoint - 80
  「新しい IIS Web サイトを作成する」を選択
  「説明」:SharePoint - (新しいポート番号)
  「ポート」:(新しいポート番号)
  「パス」:変更なし
  「認証プロバイダ」:NTLM
  「匿名アクセスを許可する」:いいえ
  「SSL を使用する」:いいえ
  「URL」:http://(サーバ名):(新しいポート番号)/
  「領域」:既定   →   「OK」をクリック

設定後 http://(サーバ名):(ポート番号)/ にアクセスしてトップページが表示、それまでに登録した内容も表示されましたが、GroupBoardへのアクセスは不可。
このため、「コントロールパネル」→「プログラムと機能」から、Microsoft GroupBoard Workspace 2007 を一旦アンインストール、その後コマンドプロンプト画面上でサーバURLを指定してgbw.msiを実行(前回の記事を参照)、これでGroupBoardにも正しくアクセス可能になり、データの継承も確認できました。

5/6追記
もうこれで大丈夫、と一安心し、SharePointで作成したバックアップファイルからの復元のテストを行ったところ、データの読み込みが不可能となってしまいました。
何とかしようといろいろ試したんですが元には戻らず、しかもそんな悪あがきの最中に3/11の大地震が発生しました。
状況も状況ですし、スキル的にも自身のレベルがこの程度では通常運用は不可能と判断、WSS3.0の導入を断念しました。
前の記事でも書きましたが、このツールには底知れないポテンシャルを感じてましたので、残念といえば残念です。もうちょっと俺自身のレベルが高ければなー(TT)。




posted by nambei-x at 16:10| Comment(0) | TrackBack(0) | PC・ネット関連 | このブログの読者になる | 更新情報をチェックする

2011年02月23日

WSS3.0 を80番以外のポートに設定してインストールする場合の備忘録(正しくないやり方編)

3/3追記
検証した結果、下記の作業は正しい手順を踏んでいなかったようです(T_T)。このまま実行した場合、それまでにSharePointに登録した内容は継承されません(なので、インストールしてすぐ行うのであれば大丈夫?)。ブログの記事は失敗例としてこのまま残しておきます。




グループウェアについて、Microsoftの WSS(Windows SharePoint Services) 3.0 とGroupBoard なるグループウェアが無料使用できる(Windows Server のライセンスが必要)ということを知り、テストを開始しました。

標準でインストールした場合、WSSのポートが80番に設定されますが、80番ポートはWSUSに使いたい、ということでWSSのポート番号を変更してみました。
ただ、今回はGroupBoardのインストール時も含め、かなりバタバタしましたので、手順を忘れないようにブログに残しておきます。

1.Windows SharePoint Services 3.0 x64 (Service Pack 2 同梱版) を入手

2.DLしたインストーラでインストール

この時点でIISマネージャ上では「SharePoint - 80」というサイトが構築されます。ポート番号は80番、Default Web Site(WSUSに使用)は停止されます。

3.「管理ツール」から新たにインストールされた「Share Point 3.0 サーバーの全体管理」をクリックするとブラウザが開きます。

4.画面左上「アプリケーションの構成」タブをクリック、「SharePoint Web アプリケーション構成の管理」〜「Web アプリケーションの作成または拡張」リンクをクリック

5.画面右「新しい Web アプリケーションの作成」リンクをクリックし、表示された画面上でポート番号その他を設定、新しいWebサイトを作成する

当初はランダムなポート番号が表示されます。ポート番号を指定したい場合、必要な個所を書き換えます。

6.ブラウザから「http://(サーバ名):(ポート番号)」にアクセス可能か確認、IISマネージャ上に新しいサイトが登録されたことを確認

7.「アプリケーション構成の管理」に戻り、「SharePoint Web アプリケーション構成の管理」の「Web アプリケーションの削除」リンクをクリック

8.画面右側の設定で、80番ポートのWebアプリを選択、データベース、IIS Webアプリともに削除を選択し、「削除」をクリック

9.IISマネージャで設定を確認、Default Web Site を起動し、動作確認、問題なければ終了

たぶんこれでオッケーだったはず(うろ覚えスミマセン)。



インストールされたWSS上に、今度はGroupBoardをインストールするのですが、これも難儀しました。
実行環境の構築・確認のためにも、GroupBoard Workspace 2007 を入手する際に、同じページから gb4setup.doc というドキュメントも一緒にDLし、熟読する必要があります。

1.GBW2007_x64_ja-jp.exe および gb4setup.doc をDL

2.DLしたファイルを任意のフォルダに解凍

3.コマンドプロンプトを起動し、CDコマンドで解凍先フォルダに移動

4.下記のコマンドを実行

Msiexec /i gbw.msi SITEURL=http://(サーバ名):(ポート番号)/

注意)
・SITEURL以下は、スペースなしで入力のこと
当初gb4setup.docに記載されたものをコピペしたが動作せず、結局"="の後ろの半角スペースを削除したところ、うまくいきました。
・URLの最後は必ず"/"で閉じること
当初「http://(サーバ名):(ポート番号)/wss」とやったところ、GroupBoard のURLは本来なら
「〜/wss/gb」となるべきところ、「〜/wssgb」となってしまいました。

5.「http://(サーバ名):(ポート番号)/gb」にアクセスし、確認

以上です。



WSSの使い勝手については、ユーザー管理がActive Directoryと連動しているようで、AD登録ユーザーであればそのIDとパスワードでログインできます。ユーザーを一元管理できるのは、管理者にとっては便利だと思います。

一方のユーザーサイドでの使い勝手はというと、正直よくわかりません。
インストール直後の状態では、多くのMicrosoft製品と同様、直観的な操作はほぼ無理、といった感じです。
もしかすると設定を変えたり、外部プラグイン等(GroupBoardもそうですが)を入れることで使いやすくなるかもしれませんが、現状のまま「これをスケジュールや情報共有に使ってください」と渡すことはできないです。
底知れない分、興味深々ではあるんですが・・・。


2/24追記
その後何をやらかしたか、上の記事を書き上げた直後からブラウザからのアクセスが不能になってしまいました。ネットワーク越し、ローカルともにです。
管理ツール内の「Share Point 3.0 サーバーの全体管理」にもアクセスできません。
IISおよびSharePoint関連サービスも正常動作していると思われ、原因不明のためいったんリフレッシュしようと思い、GroupBoardをアンインストールしましたが、WSS3.0については「プログラムと機能」でのアンインストール、インストーラを起動しての削除ともに失敗してしまいます。

結局今朝、インストーラから修復〜管理ツール内の「SharePoint 製品とテクノロジ構成ウィザード」実行でアクセス可能になり、以前に登録したユーザーデータやスケジュールも問題なく読み込まれていましたが、使用不能になった原因が不明ですし、今のところびくびくしながら様子を見ている状態です。



posted by nambei-x at 12:29| Comment(0) | TrackBack(0) | PC・ネット関連 | このブログの読者になる | 更新情報をチェックする

2010年12月12日

Aipo5 を Vista で動作させるための設定 (非推奨)

※インストール後に気付いたんですが、Aipo5の動作環境はWindowsXP、2000、2000Server、2003ServerプラスCent0S5.0で動作確認済み、となっていました。
よって今回の記事は、サービス提供者のサポート適用範囲外となりますのでご承知置き願います。

動作環境について│製品紹介|無料グループウェア 『アイポ5』

『アイポ』 ユーザーコミュニティ - v​i​s​t​a​で​の​利​用​に​つ​い​て



前回の記事で、Aipo5およびGroupSession3をインストールした、と書きました。
インストール先OSはVistaとWin7の2種類。それぞれに2つのグループウェアをインストールし、プロキシ設定を変更後、実行したところ、4パターンのいずれも正常動作を確認しました。
(Aipo5についてはWin7にインストールの際、エラーが出てインストールが失敗しました。これは「SecondaryLogon」というサービスを自動起動に設定することで解決しています。)

その後PCの再起動を行ったところ、GroupSessionおよびWin7上のAipoは正常に自動起動したんですがVista機のAipoだけ、まともに動かなくなりました。
具体的に言うと、スタートアップに登録された「Aipoマネージャー」という管理ツールの「停止」「開始」「開く」ボタンが正しく機能していない状態です。

20101212_1908763.jpg

また、この状態で「http://(自身のIPアドレス)/aipo」にアクセスしても、Aipo自身が404エラーを返します。

20101212_1908764.jpg



これの原因を調べていて、以下のことが分かりました。

1.Aipoがブラウザ上で正常に動作するためには AipoPostgreSQLおよびAipoTomcatなるサービスが正常に機能していることが必要だが、そのためには起動順序がAipoPostgreSQL→AipoTomcatの順になっていること

2.Aipoマネージャーはこの2つのサービスが正常に動作していないと動かない

3.Vista環境においては、その厳密なユーザーアカウント管理が一部のアプリケーションの動作に不具合をもたらす可能性があり、Aipoマネージャーもその一つである




これらから、試行錯誤の上、下記のような対応で一応、動作するようになりました。

1.「コンピュータの管理」→「サービスとアプリケーション」→「サービス」 において、「AipoTomcat」のプロパティ「全般」→「スタートアップの種類」を「自動(遅延開始)」に変更

20101212_1908766.jpg

2.Aipoマネージャーをスタートアップから外し、手動で実行するか、遅延起動スクリプトをスタートアップに登録するなどして、AipoPostgreSQLおよびAipoTomcatが正常に起動した後でAipoマネージャーが起動するようにする

3.C:\aipo\dpl003\bin\AipoManager.exe のプロパティ→「互換性」タブで、「管理者としてこのプログラムを実行する」にチェック

20101212_1908765.jpg




ここまで設定後、PCを再起動、スタートアップに登録した遅延起動スクリプトは、起動から2分後にAipoマネージャーが立ち上がるように設定しており、しばらく待ったところ、UACの確認画面が表示され、「許可」を選択したところ、Aipoマネージャーが立ち上がり、「停止」「開始」および「開く」ボタンが正常に動作しました。

20101212_1908767.jpg



・・・と、推奨外の環境でAipoを無理やり動かすことには成功しました。
今回はローカルサーバ上での運用ということで、実際にこの環境で運用を開始したとしてもそんなに大きな問題は起こらないとは思うんですが、やっぱり万が一のことを考えると、サービス提供者が動作確認していない環境は不安ではあります。
WindowsについてXPまでしか対応していないというのはどういうこと?と思ったりもするんですが、こういうツールの運用は WindowsよりもLinux環境の方がふさわしいんでしょうね。
Windowsは事実上Vistaか7か、この2つしか選べませんので、Linux環境を構築した上でAipoを使うか、Vistaまたは7の上でGroupSessionを使うか、クライアント側での使い勝手やメンテナンスのしやすさも含め、まだまだ検討の余地がありそうです。


posted by nambei-x at 23:04| Comment(0) | TrackBack(0) | PC・ネット関連 | このブログの読者になる | 更新情報をチェックする
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。